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Introduction 
 

This guide provides detailed guidance on how to use the Road Ranger Inspection 
Program (RRIP)—a mobile Tablet PC application designed to record and query data from 
field inspections of Road Ranger service patrol vehicles.  Specifically, the application 
provides the following capabilities: 
 

• Record violations of Road Ranger service patrol vehicles 
• Calculate the total fines from violations 
• Verify violations and provide receipts signed by Road Ranger drivers 
• Generate violation reports in a PDF file that includes pictures showing vehicle 

damages 
• Email violation reports from the field to contractors  
• Retrieve and view existing inspection records 
• Generate standard summary reports for specific time periods, contractors, etc. 

 
This guide assumes that the user is familiar with the general operations of Microsoft 
Windows Tablet PC Edition. For general help on using Windows such as managing the 
environment, the file system and printing, please refer to the Microsoft Windows User’s 
Guide. 
 

Setting up the System 
Minimum System Requirements 

 
RRIP requires a Tablet PC with a minimum 1024x768 display resolution.  A higher 
resolution can be used, but is not recommended because the screen on the Tablet PC may 
become too small to read, especially when it is under the sun.  In addition, if you want to 
be able to create and email violation reports to contractors, you will need to install a PDF 
writer in your Tablet PC.  Adobe Acrobat 7.0 Professional is recommended for this 
purpose.  Refer to the next page on how to set up the output PDF file path for RRIP. 

 

Installing RRIP Application 
 

Insert your RRIP CD into the CD drive of your Tablet PC and wait for a few seconds for 
the install program to automatically start. Follow the instructions on the screen to 
complete the installation.  If you are using a flash drive or a memory stick, you will need 
to double tap the setup.exe file to start the install program. 
 
Note: If your computer is already installed with a previous version of RRIP, you will be 
prompted to remove the existing version before installing a newer version of RRIP. 
Remember to backup your RRIP.mdb database file before you choose to remove the 
previous version. 
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Setting Output File Path for PDF Writer 
 

An Adobe PDF Writer is needed for you to create violation summary reports to be 
emailed to contractors as email attachments.  This program must be purchased and 
installed separately from RRIP.  
 
After the PDF Writer is installed, you will need to setup the default folder for the PDF 
output files so that RRIP will know where to find the PDF files.  The steps to reset the 
default folder are as follows: 
 

1. Click Start > Print and Faxes to open the screen shown in Figure 1. 
 
2. Right click Adobe PDF and select Properties to open the Adobe PDF 

Properties window shown in Figure 2.  Select the Advanced tab and click the 
Printing Defaults… button to bring up the screen shown in Figure 3. 

 
3. Select the Adobe PDF Settings tab and set Adobe PDF Output Folder to the 

RRIP program folder.  The default RRIP folder for this purpose is: “c:\Program 
Files\RRIP\PDF” (see Figure 3).  The recommended options for the checkboxes 
in Figure 3 are as shown. 

 
 

Figure 1: Print and Faxes 
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Figure 2: Adobe PDF Properties Setup 
 

 
 

 
Figure 3: Adobe PDF Printing Setup 
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Entering Data in the Field 
 
To start running RRIP to collect field data, double tap the shortcut icon             ur 
desktop.  You can also do so from the Start menu by selecting: 

on yo

 
Start > All Programs > RRIP 1.0 > RRIP 1.0 

 
This will open the main screen of the program, which consists of a series of tabs for data 
entries and data queries. 
 
The data entries for each inspection are done within the first four tabs below: 
 

• General Information 
• Vehicle/Equipment/Safety/Uniform/Misc Inspection 
• Light Inspection 
• Summary Report 

 
The General Information tab, as shown in Figure 4, is the first screen displayed when 
you first enter the program.  The screen allows you to specify the name of inspector, date, 
contractor, vehicle/driver, contact number, type of assist, state road number, and location 
description.  The name of the inspector and the type of assist will automatically be kept 
for the next record until the selection is changed.  By default, the inspection date is 
today’s date.   
 
The second half of the screen lists all of the existing inspection records in the database.  
The current record is indicated with a small pointing arrow.  You may double tap a 
specific record from the table to retrieve and display the data on the forms displayed in 
various tabs. 
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Figure 4: General Information Screen 
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As shown in Figure 5, the Vehicle/Equipment/Safety/Uniform/Misc tab allows you to 
check if a specific item related to vehicle, equipment, driver, etc., is in violation. Tap Yes, 
No, or NA to specify whether a checking item is not in violation, is in violation, or is not 
applicable, respectively.  You may also tap the column header to toggle to select or 
unselect Yes, No, or NA for all items in a specific category at once. 
 
 

Figure 5: Vehicle/Equipment/Safety/Uniform/Misc Checking Screen 
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The Light Inspection tab shown in Figure 6 allows you to use the digitizer pen to mark 
any non-functional lights as well as other vehicle damages.  In this screen, you can also 
tap the Clear button to start the marking all over again.  You can tap the Add Photo 
button to include multiple photos in the PDF summary report file.  A dropdown box is 
included to allow you to preview specific photos, which is shown below the dropdown 
box one at a time.  The screen also allows you to add a comment of up to 255 characters. 
 
 

Figure 6: Light Inspection Checking Screen 
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The Summary Report tab, as shown in Figure 7, allows you to view the standard 
summary report, which summarizes the complete inspection results and shows the total 
fine for all violations.  The driver can review the report in the field before signing it to 
acknowledge that the inspection took place and that the report is accurate. 

 
 

  Figure 7: Summary Report Screen 
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At the bottom of the tabs described above, the following buttons are available: 
 
• The New button allows you to add a new record.  The current record must be saved 

first before a new record can be added.  
 
• The Previous button allows you to go to the previous record.  
 
• The Next button allows you to go to the next record. 

 
• The Save button allows you to save/update the current record.  

 
• The Delete button allows you to delete the current record. Important: A deleted 

record is deleted permanently from the database and cannot be recovered. The 
deleted Case ID cannot be reused. 
 

• The Print button (or File > Print Report Form menu item) allows you to print the 
current summary report form. Before printing, you can also select File > Print 
preview… to preview and print the report. 
 

• The Email button allows you to send an email to the contractor with cc: to the 
inspector.  RRIP will automatically start the default email system with the current 
summary report form attached as a PDF file.  Figure 8 shows such an email. 

 
 

Figure 8: Sample Email Screen 
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Customizing Selection Options 
 
RRIP allows you to customize the list items for inspector, contractor, contract number, 
vehicle/driver, state road, and type of assist.  For each list, you may view, update, delete 
its existing selections or add new selections to it. 
 
To modify an existing selection list, tap the File > General Info Setup… menu item.  
This will bring up the General Information Setup Form shown in Figure 9.  The form 
consists of a series of tabs, one for each of the selection lists that you can modify. 
 

• The Inspector tab includes the inspector name and the inspector’s email address 
(see Figure 9). The inspector’s email address will be the default cc: email address.  

 
• The Contractor tab includes the contractor name and the contractor’s email 

address (see Figure 10).  The contractor’s email address is used as the default for 
the To: email address. 

 
• The Contract Number tab includes the contractor name and the contract number 

(see Figure 11).  All the available contract numbers for a selected contractor are 
listed in the Contract Number dropdown list. 
 

• The Vehicle/Driver tab includes the contractor name and the vehicle number as 
well as some other detailed vehicle information (see Figure 12).  All the available 
vehicle numbers for a selected contractor are listed in the Vehicle/Driver 
dropdown list.  

 
• The State Road tab includes the ID and state road name (see Figure 13).  All the 

state road names are listed in the State Road dropdown list.  
 

• The Type of Assist tab includes the ID and the different assist types (see Figure 
14).  The assist types are listed in the Type of Assist dropdown list. 

 
To add a new selection, tap the New button and then enter the requested information 
listed on top of the table. 
 
To modify an existing selection option, select the record corresponding to the option by 
using the navigational buttons or by tapping the record in the table directly.  Enter the 
new text in the textbox and then tap the Save button to save the changes. 
 
To delete an existing record, navigate to the record or tap the record within the table 
directly and then tap the Delete button.  After all the changes are made, tap Ok to close 
the form. 
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Figure 9: Inspector Setup 

 
 

Figure 10: Contractor Setup 
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Figure 11: Contract Number Setup 
 

 
 

Figure 12: Vehicle/Driver Setup 

 

 12



Figure 13: State Road Setup 
 

 
 

Figure 14: Type of Assist Setup 
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Querying the Database 
 
RRIP provides a simple query function to generate the following three summary reports: 
 

• The Total Summary report lists the total number of inspections and the 
associated total amount of fines for each contractor. 

 
• The Vehicle Summary report lists the number of inspections and the associated 

total amount of fines for each vehicle. 
 

• The Detailed Report lists all the inspection records with a list of violation found 
in each inspection plus the total amount of fines for each inspection. 

 

Query Setup 
 
RRIP provides two types of filters to limit the types of inspection records to include in 
your summary reports, i.e., with or without the case ID: 
 

1. With Case ID: Tap the Query Setup tab and enter a specific case ID at the Case 
ID textbox.  As soon as the first character is entered in the Case ID textbox, the 
system will disable all other fields on the screen (see Figure 15).  After a case ID 
is specified, tap the Query button to run the query. 

 
2. Without Case ID: If you leave the textbox for Case ID empty, the system will 

assume that you will use the other variables as your filters (see Figure 16).  By 
default, no filters are applied, which means that all inspection records will be 
included in the reports.  To limit your reports to, for example, a specific time 
period, specify the From and To dates for the period.  You can further specify to 
include a specific type(s) of violation by checking the Yes, No, and N/A 
checkboxes, as appropriate.  Tap the Query button to run the query. 

 
Note: The query criteria among the dropdown and date variables are based on 
the “and” Boolean operator and the query criteria among the checkboxes are 
based on the “or” Boolean operator.  The query criterion between these two 
groups of criteria is based on the “and” Boolean operator.  For example, in 
Figure 16, this query will include all inspection records during the period of Jan 
19, 2007and Feb 19, 2007, “and” were inspected by Inspector1, “and” the 
Contractor is Sunshine Towing Inc. “and” the violations include only those with 
No Spot Light / Flash Light or No Battery Cables. 
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Figure 15: Query with Case ID    
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Figure 16: Query without Case ID      

 
 

Query Output 
 
After you tap the Query button to run the query, you can tap the Query Output tab to 
see the query output. As mentioned, the query output includes the following three 
summary reports: Total Summary, Vehicle Summary, and Detailed Report. An example 
output is shown in Figure 17.  Tap the Print button to print all three tables at once or tap 
the Print Preview to preview and print individual tables. 
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Figure 17: Query Output 

       
 

Help 
 
Tap the Help > User’s Guide menu item to access this User's Guide. 

 

Exit 
 
This button allows you to exit from RRIP completely.  It serves the same function as the 
standard Close button on the top-right corner of the screen. 
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